Passer au contenu du forum

Forum du RHIEN

Forum d'entraide pour le Réseau des Hébergeurs Indépendants et Engagés

Vous n’êtes pas identifié. Veuillez vous connecter ou vous inscrire.


Ecrire une réponse

Ecrire une réponse

Composez et envoyez votre nouvelle réponse

Vous pouvez utiliser : BBCode Images Binettes

Les champs marqués %s doivent être remplis avant d’envoyer ce formulaire.

Information obligatoire pour les invités



Captcha image. Turn pictures on to see it.
Information obligatoire

Revue du sujet (plus récents en tête)

14

Il suffit de virer l'instruction AddDefaultCharset

13

Pour ce thème, c'est bon en fait.

la personne chargée de ça va recoder les caractères non pris en compte.

Merci pour l'aide wink

12

Les caractères erronés viennent de pages texte simple ou ressortent d'une interrogation à une base de données? Parce que la connexion au SGBD peut aussi être configuré en utf-8

si c'est du fichier texte simple (enfin html), avec la commande file (ou file -i) tu as des fois l'encodage, tu peux donc ensuite les convertir en utf-8 avec la commande iconv

11

Allez, balancez vos idées.

Je vais à la boite vers 15h. J'aimerai avoir plusieurs choses à tester au cas ou que la solution juste avant ne fonctionne pas wink


Merci

10

Je retourne demain à la boite, je pourrais tester ça.

Si vous avez d'autres propositions, balancez, que je test tout ça demain wink

Merci

9

Commente la ligne qui se trouve dans /etc/apache2/apache2.conf

8

Charset est géré dans deux fichiers

/etc/apache2/apache2.conf
et
/etc/apache2/charset

j'ai commenté celui de :
/etc/apache2/apache2.conf

et changé celui de:
/etc/apache2/charset

7

Sur une Debian tu as un fichier charset dans /etc/apache2/, c'est bien celui-ci que tu as modifié ?

6

Sur la machine d'avant (un fedora core), avec apache2, ça marchait bien.

Tous les sites étaient bien visualisés (que ça soit en UTF-8 ou ISO-8859-15).

Et là , réinstallation du système par une debian, avec toujours apache2, et ça merde.

D'autres idées pour résoudre ça?

5

J'peux pas car en fait, les sites sont tous dans un répertoire (c'est pour des gens qui travaillent en local), il n'y a pas de VirtualHosts.

donc tout est dans /var/www/lesite/ et sous firefox on tape:

http://labete/lesite/   (labete c'est du netbios !!! big_smile à ce niveau là c'est pas moi qui ait choisi)

Pour faire clair, c'est dans une boite, et je réinstalle au fur et à  mesure les serveurs. Je mettrais tout en DNS quand je réinstallerai un autre serveur ou je mettrai bien dessus.

4

heu tu pourrais peut etre essayer par passer par un .htaccess pour chaque hebergé ou y'a soit de l'iso soit de l'utf?

3

J'ai essayé:

AddDefaultCharset Off

et également:

AddDefaultCharset On

mais pareil, ça inverse l'erreur (en fonction du format de la page), mais ça règle pas le problème hmm


Et AddDefaultCharset UTF-8, ça merde quand sur le site ça charge les données d'un XML. Est-ce que ça pourrait venir d'ailleur qu'apache?

2

AddDefaultCharset Off

1

Bonjour, (ou plutôt bonsoir),

J'ai un problème d'hébergement web.

J'ai installé une debian (etch, toute dernière stable), avec comme locales UTF-8 et ISO8859-15.

J'ai installé apache2. Certaines pages ressortent sans problèmes et d'autres pages ressortent avec des caractères non compris.

Dans la configuration d'apache2, quand je mets:

AddDefaultCharset UTF-8

, les pages en format ISO8859-15 ressortent avec des caractères mal compris,

et quand je met

AddDefaultCharset ISO8859-15

, c'est évidemment les pages en UTF-8 qui ressortent avec des caractères erronés.

Je cherche une solution pour que tout cohabite sans problèmes.

C'est pourquoi je fais ma demande ici (et ça tombe bien car actuellement le statut du RHIEN ramène beaucoup de gens sur le forum pour en débattre wink

Merci d'avance.


Currently installed 2 official extensions. Copyright © 2003–2009 PunBB.