Passer au contenu du forum

Forum du RHIEN

Forum d'entraide pour le Réseau des Hébergeurs Indépendants et Engagés

Vous n’êtes pas identifié. Veuillez vous connecter ou vous inscrire.


Ecrire une réponse

Forum du RHIEN » Hébergement » Configuration Apache2 » Ecrire une réponse

Ecrire une réponse

Composez et envoyez votre nouvelle réponse

Vous pouvez utiliser : BBCode Images Binettes

Les champs marqués %s doivent être remplis avant d’envoyer ce formulaire.

Information obligatoire pour les invités



Captcha image. Turn pictures on to see it.
Information obligatoire

Revue du sujet (plus récents en tête)

14

HaMshiva a écrit:

Interface --> Cartes réseaux

Si tu as plusieurs cartes réseaux tu as probablement plusieurs IP et tu peux choisir d'avoir un virtualhost sur une interface et pas sur l'autre.

Bof, maintenant la plupart des PC ont 2 cartes réseaux.

13

Interface --> Cartes réseaux

Si tu as plusieurs cartes réseaux tu as probablement plusieurs IP et tu peux choisir d'avoir un virtualhost sur une interface et pas sur l'autre.

12

Interface ?

11

Attention, il peut être intéressant de spécifier l'adresse IP plutôt que * quand on possède plusieurs interfaces sur le serveur, sinon * est très pratique !

10

Alexismoy a écrit:

Oui mais ça, ça s'adapte à sa configuration wink

Si t'as plusieurs adresses IP, et que tu les utilises pour le même site, alors *:80 fonctionnera également wink

+1

9

Oui mais ça, ça s'adapte à sa configuration wink

Si t'as plusieurs adresses IP, et que tu les utilises pour le même site, alors *:80 fonctionnera également wink

8

Euh oui et non. Dans le tuto, il est question de l'IP locale de la machine, pas d'une *

7

Ton tuto, c'est ce que je t'ai dis de faire smile

Ajouter "NameVirtualHost *:80"

et également "ServerName www.ton.domaine.tld"

Juste qu'il fallait modifier aussi, <VirtualHost *> par <VirtualHost *:80>

6

Yahoo !

C'est bon, c'est réglé, et en fait, c'était tout con (maintenant, j'ai honte, vous imaginez même pas!)

Voici l'explication, pour ceux que ça intéresserait.

PS : Merci Alexismoy

5

Arf... encore une erreur :

[Sat Feb 10 01:35:20 2007] [warn] VirtualHost ehia.org:0 overlaps with VirtualHost revolution.ehia.org:0, the first has precedence, perhaps you need a NameVirtualHost directive
[Sat Feb 10 01:35:20 2007] [warn] NameVirtualHost *:80 has no VirtualHosts

4

Ajoute ceci tout en haut de ton fichier 000-default:

NameVirtualHost *:80

et ensuite, dans la balise <VirtualHost> (toujours de 000-default)

ServerName www.ton.domaine.tld                     # <= ça c'est le domaine qui te permettra d'accéder au site qui se trouve dans /var/www


Je ne dis pas que c'est la meilleur solution, ni l'unique solution, mais ça fonctionne comme ça chez moi.

3

Ouais... maitenant les deux me donnent l'index du /var/www/

<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

2

Ton problème vient surement de ça:

RedirectMatch ^/$ /apache2-default/

qui doit êre présent dans ton fichier 000-default (je ne pense pas qu'il soit utile d'expliquer ce que ça veut dire).



Il doit également y avoir un problème dans tes fichiers,

Car logiquement, il ne devrait pas prendre en compte le fichier 000-default vu que t'utilises un autre fichier pour ce sous-domaine.

Fais un C/C du fichier 000-default pour voir wink

1

Salut les gens !

Suite à la conversation sur les ISP, j'ai décidé de me lancer dans une configuration complètement maison... Seulement, à peine trois mètre après le départ, je me vautre déjà.

Voici le topo, dans mon /etc/apache2/site-enabled/ j'ai deux fichiers
* 000-default
* revolution.ehia.org

Le 000-default est resté par défaut, et voici l'autre :

<VirtualHost *>
        ServerAdmin akyrho@ehia.org
        ServerName revolution.ehia.org
        DocumentRoot /var/www/revolution
        <Directory /var/www/revolution>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog /var/log/apache2/revolution_error.log
        LogLevel warn
        CustomLog /var/log/apache2/revolution_acess.log combined
        ServerSignature Off
</VirtualHost>

L'astuce est dès que je saisi revolution.ehia.org dans mon navigateur, il me renvois vers http://revolution.ehia.org/apache2-default/, comme si il prenait seulement le fichier 000-default en compte.

Un p'tit coup de main serait bien charitable  :aie:

AkyRhO, merdique en conf apache

Forum du RHIEN » Hébergement » Configuration Apache2 » Ecrire une réponse


Currently installed 2 official extensions. Copyright © 2003–2009 PunBB.